Apple заставляет будущие приложения iOS поддерживать 64-разрядную версию

Apple официально объявила, что с 1 июня 2015 года все разработчики приложений для iOS хотят обновить текущие приложения, они должны поддерживать 64-разрядную версию.

Изображение 1: Apple заставляет будущие приложения iOS поддерживать 64-разрядную версию

17 декабря Apple опубликовала уведомление, напоминающее разработчикам, что с 1 февраля 2015 г. новые приложения, размещенные в App Store, должны будут поддерживать 64-разрядные версии и должны быть построены на основе набора инструментов iOS 8 SDK. С 1 июня 2015 г. текущие приложения, которые хотят обновить до новой версии, также должны соответствовать указанным выше требованиям Apple. Компания поделилась с разработчиками, что, используя X-код, созданный «стандартные знания» , они могли создать единый двоичный файл как для 32-битных, так и для 64-битных систем.

Новое правило Apple не повлияет на старые iPhone, потому что приложения могут загружать 32-разрядную среду выполнения для обратной совместимости с этими устройствами.

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *